My.elementor
Incident Report for Elementor
Resolved
This incident has been resolved.
Posted Jan 19, 2023 - 19:04 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 19, 2023 - 19:03 UTC
Investigating
Some of our users might experience Issues when trying to log in My.elementor
Posted Jan 19, 2023 - 18:37 UTC
This incident affected: Elementor Dashboard.