Hosting degraded performance issues
Incident Report for Elementor
Resolved
This incident has been resolved.
Posted Dec 22, 2022 - 08:56 UTC
Investigating
Some of our hosted sites might have degraded performance issues. The issue is investigated.
Posted Dec 22, 2022 - 05:58 UTC
This incident affected: Elementor Cloud Websites (Hosting).