Global support degraded performance
Incident Report for Elementor
Resolved
Our third-party support systems are back up and operational.
Posted Apr 15, 2024 - 14:49 UTC
Investigating
Currently, we are having degraded performance with our CRM system. The issue affects creating new support conversations and might affect handling time. The issue is in investigation.
Posted Apr 15, 2024 - 12:32 UTC
This incident affected: Elementor Services (Global Support Services).