unable to access My Elementor

Incident Report for Elementor

Resolved

This incident has been resolved.
Posted May 13, 2025 - 09:59 UTC

Identified

We’re currently experiencing an issue causing the My Elementor page to be unavailable.

As a result, some users may not be able to access their sites or settings.

Our team is actively working to resolve this as quickly as possible.

We apologize for the inconvenience and appreciate your patience.

We’ll post an update here as soon as the issue is resolved.
Posted May 13, 2025 - 09:26 UTC