Support Chat icon is invisible
Incident Report for Elementor
Resolved
This incident has been resolved.
Posted Jun 19, 2022 - 17:26 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 19, 2022 - 17:08 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 19, 2022 - 16:46 UTC
Investigating
The Elementor support chat icon is currently hidden in the lower-right corner. Elementor's support chat function is working; you can access it by moving your mouse over the area. The cursor will become a pointing finger over the spot where you would normally see the chat icon. When the cursor changes into a pointing finger, click and the Elementor support chat function opens.
Also, you can go to Contact the Elementor Team for Any Question
Posted Jun 19, 2022 - 14:43 UTC
This incident affected: Elementor Services (Elementor.com).