Elementor Plugin Non-Functional on Host Sites

Incident Report for Elementor

Resolved

The issue is now resolved. If your site is still affected, you can restore site functionality by manually reinstalling the Elementor plugin:

Navigate to Plugins → Add New in the WordPress dashboard
Search for Elementor then click Install and Activate or contact support.
Posted Jan 07, 2026 - 18:03 UTC

Investigating

We are aware of a possible issue with Elementor installations and are actively investigating.
Posted Jan 07, 2026 - 17:16 UTC
This incident affected: Elementor Cloud Websites (Hosting).