Live Chat Unavailable

Incident Report for Elementor

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 11:13 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2025 - 07:04 UTC

Identified

Our live chat is experiencing an issue that might prevent you from initiating or conducting support conversations.
Our teams are working on fixing the issue.
We apologize for the inconvenience. In the meantime, if our virtual assistant does not answer your query, please submit a support request through my.elementor.com/support-form/.
Posted Mar 26, 2025 - 06:37 UTC