2FA Issue
Incident Report for Elementor
Resolved
This incident has been resolved.
Posted Feb 27, 2024 - 11:57 UTC
Investigating
We are currently investigating an issue of users not receiving 2FA codes.
Posted Feb 27, 2024 - 11:27 UTC
This incident affected: Elementor Services (Elementor.com, Global Support Services).