Degraded Performance
Incident Report for Elementor
Resolved
This incident has been resolved.
Posted Jul 29, 2023 - 20:09 UTC
Investigating
Some of our hosting customers might experience degraded performance due to an incident on google cloud service. We are working closely with Google to resolve the incident.
Posted Jul 29, 2023 - 19:30 UTC
This incident affected: Elementor Cloud Websites (Hosting).