Partial outage of Elementor services
Incident Report for Elementor
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 08:19 UTC
Update
Cloudflare has released a fix to its service and some services have returned to their normal operation. Elementor is continuing to monitor the situation with Cloudflare's service and will continue providing updates as needed.
Posted Jun 21, 2022 - 07:45 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 21, 2022 - 07:30 UTC
Monitoring
Cloudflare is experiencing a technical issue which is affecting some websites and services administered by Elementor . Cloudflare is aware of this issue and their technical staff is working on restoring service as soon as possible.
We are continuing to monitor this issue.
Refresh this status page for updates
Posted Jun 21, 2022 - 07:29 UTC
This incident affected: Elementor Services (Elementor.com, Kits, Licenses, Connect) and Elementor Cloud Websites (Hosting, Operations, Domains).