Elementor license connect issue

Incident Report for Elementor

Resolved

This incident has been resolved.
Posted Jan 27, 2025 - 15:32 UTC

Identified

There is currently an issue where some users cannot connect their license keys or see their licenses as disconnected.

We are actively working to resolve this issue as quickly as possible and appreciate your patience.

We will provide updates here as soon as more information is available.
Posted Jan 27, 2025 - 11:49 UTC