Availability issue
Incident Report for Elementor
Resolved
This incident has been resolved.
Posted May 22, 2022 - 11:35 UTC
Update
We are continuing to investigate this issue.
Posted May 22, 2022 - 09:18 UTC
Update
We are continuing to investigate this issue.
Posted May 22, 2022 - 09:17 UTC
Investigating
Elementor is aware of an availability issue on our cloud hosting solution and is investigating it.
Customers might have issues with accessing their sites (hosted on Elementor Cloud).
Further details will be provided as more information becomes available.
Posted May 22, 2022 - 09:14 UTC
This incident affected: Elementor Cloud Websites (Hosting).