Partial outage
Incident Report for Elementor
Resolved
This incident has been resolved.
Posted Aug 22, 2022 - 19:04 UTC
Update
We are continuing to investigate this issue.
Posted Aug 22, 2022 - 17:59 UTC
Investigating
Elementor is aware of an availability issue on our cloud hosting solution and is investigating it.
Posted Aug 22, 2022 - 15:59 UTC
This incident affected: Elementor Cloud Websites (Domains).